[Oisf-devel] icmpv6 type #defines

David Mandelberg dmandelb at bbn.com
Wed Dec 5 22:00:04 UTC 2012


Hi,

In src/decode-icmpv6.h, there are some #defines for ICMPv6 types:

/** ICMPV6 Message Types: */
/** Error Messages: (type <128) */
#define ICMP6_DST_UNREACH             1
#define ICMP6_PACKET_TOO_BIG          2
#define ICMP6_TIME_EXCEEDED           3
#define ICMP6_PARAM_PROB              4

/** Informational Messages (type>=128) */
#define ICMP6_ECHO_REQUEST          128 
#define ICMP6_ECHO_REPLY            129

#define MLD_LISTENER_QUERY          130
#define MLD_LISTENER_REPORT         131
#define MLD_LISTENER_REDUCTION      132


Why don't the last three start with ICMP6_? If I want to add more types,
should I name them e.g. NDP_ROUTER_SOLICITATION,
ICMP6_ROUTER_SOLICITATION, or ICMP6_NDP_ROUTER_SOLICITATION?



More information about the Oisf-devel mailing list