[Oisf-devel] Mingw Suricata Build

Rich Rumble richrumble at gmail.com
Fri Apr 15 12:02:39 UTC 2011

I've tried all I can think of, gone over the instructions
more than a few times too... One error is
pcap-config not found (not pkg-config) and the
other is somehow due to pkg-config.
I set the PKG_CONFIG_PATH in both the User
and System Environment variables and tried it
in each by one at a time (reboots and all). The
instructions didn't say which variable to set
it in so I tried both...

With the latest Git I still error out with:
checking for pfring_set_cluster in -lpfring... no
checking pcap.h usability... yes
checking pcap.h presence... yes
checking for pcap.h... yes
checking for pcap_open_live in -lpcap... yes
checking for pcap_activate in -lpcap... yes
./configure: line 14895: pcap-config: command not found
./configure: line 14895: pcap-config: command not found
checking for pcap_set_buffer_size in -lpcap... yes
./configure: line 15122: syntax error near unexpected token `LIBHTPMINVERSION,'
./configure: line 15122: `        PKG_CHECK_MODULES(LIBHTPMINVERSION,
htp >= 0.2.3,libhtp_minver_found="yes",libhtp_minver_fo

More information about the Oisf-devel mailing list