[Oisf-devel] Suricata 1.2.1 + OpenBSD

Steve Grubb sgrubb at redhat.com
Thu Apr 26 14:15:44 UTC 2012

On Thursday, April 26, 2012 08:53:17 AM Henri Wahl wrote:
> I run Suricata on CentOS Linux 5.8 where it does a great job. I also
> want to run it on OpenBSD but there it fails badly. I tried to compile
> stable suricata 1.2.1 and unstable 1.3beta1 on OpenBSD 4.9, 5.0 and 5.1
> with gcc 4.2.1 and the result is always a break in compiling with this
> output:
> gcc -DHAVE_CONFIG_H -I. -I..  -I../libhtp   -I/usr/local/include
> -I/usr/local/include/libnet-1.1  -DRELEASE -Wextra -Wall
> -fno-strict-aliasing -fno-tree-pre -Wno-unused-parameter -std=gnu99
> -D__OpenBSD__ -march=native  -I/usr/local/include
> -MF .deps/util-ioctl.Tpo -c -o util-ioctl.o util-ioctl.c
> util-ioctl.c: In function 'GetIfaceMTU':
> util-ioctl.c:74: error: storage size of 'ifr' isn't known

This means that SIOCGIFMTU is defined but either "struct ifreq" is not supported 
or its in a different header file. See if you can find what header file its in and 
let everyone know or maybe you'll have to get rid of some ./configure option.


More information about the Oisf-devel mailing list