[Oisf-users] [oisf-users] pcre.h not usable error with suricata latest from git

Josh White josh at securemind.org
Wed Jan 11 16:20:07 UTC 2012

I'm trying to compile the latest git version of Suricata on a powerpc based
appliance today. Previous versions have been successful but 1.1.1 and
beyond are producing the following.

./configure  and all ./configure --with-libpcre-libraries=
--with-libpcre-includes= options I've tried also produce the same:

checking host os... installation for powerpc-unknown-linux-gnu OS... \cok
checking pcre.h usability... no
checking pcre.h presence... yes
configure: WARNING: pcre.h: present but cannot be compiled
configure: WARNING: pcre.h:     check for missing prerequisite headers?
configure: WARNING: pcre.h: see the Autoconf documentation
configure: WARNING: pcre.h:     section "Present But Cannot Be Compiled"
configure: WARNING: pcre.h: proceeding with the preprocessor's result
configure: WARNING: pcre.h: in the future, the compiler will take precedence
checking for pcre.h... yes
checking for pcre_get_substring in -lpcre... no

   ERROR!  pcre library not found, go get it
   from www.pcre.org.

libpcre is present:

whereis libpcre
libpcre: /usr/lib/libpcre.so

pcre.h is present:
whereis pcre.h
pcre: /usr/include/pcre.h /usr/share/man/man3/pcre.3.gz

compiled pcre from scratch and ran suricata ./configure
--with-libpcre-includes=/opt/pcre-8.20-RC3/include/ where then produces the
exact same error.

any suggestions,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openinfosecfoundation.org/pipermail/oisf-users/attachments/20120111/a3e59f13/attachment-0002.html>

More information about the Oisf-users mailing list