[Oisf-users] Problems compiling suricata 1.3 under CentOS 6.3

C. L. Martinez carlopmart at gmail.com
Wed Jul 11 10:29:44 UTC 2012

On Wed, Jul 11, 2012 at 12:20 PM, Victor Julien <victor at inliniac.net> wrote:
> On 07/11/2012 12:01 PM, C. L. Martinez wrote:
>> Hi all,
>>  I am trying to compile suricata under CentOS 6.3 kvm guest for
>> testing, but configure returns me this error:
>> checking pcre.h presence... yes
>> configure: WARNING: pcre.h: present but cannot be compiled
>> configure: WARNING: pcre.h:     check for missing prerequisite headers?
>> configure: WARNING: pcre.h: see the Autoconf documentation
>> configure: WARNING: pcre.h:     section "Present But Cannot Be Compiled"
>> configure: WARNING: pcre.h: proceeding with the compiler's result
>> checking for pcre.h... no
>> configure: error: pcre.h not found ...
>> pcre-devel package is installed and I have tried to configure using
>> --disable-gcc-march-native switch without luck. Where is the problem??
> Please try --disable-gccmarch-native instead.
> --

Thanks Victor, now it works but returns me another error:

checking magic.h usability... no
checking magic.h presence... no
checking for magic.h... no
configure: error: magic.h not found ...

kernel, kernel-devel and kernel-headers are installed ... Launching
configure on another CentOS 6.2 host doesn't returns me this error ...

More information about the Oisf-users mailing list