[Oisf-users] Tuning Suricata (2.0beta1) -- no rules and lots of packet loss

Peter Manev petermanev at gmail.com
Sat Aug 24 07:23:28 UTC 2013

On Fri, Aug 23, 2013 at 8:27 PM, Cooper F. Nelson <cnelson at ucsd.edu> wrote:
> Hash: SHA1
> I tried building the latest version from git and it died with this error:
>> suricata.c: In function 'SCPrintBuildInfo':
>> suricata.c:677:50: error: 'defined' undeclared (first use in this function)
>> suricata.c:677:50: note: each undeclared identifier is reported only once for each function it appears in
>> suricata.c:677:50: error: expected ')' before numeric constant
>> make[3]: *** [suricata.o] Error 1
>> make[3]: Leaving directory `/usr/src/oisf/src'
>> make[2]: *** [all] Error 2
>> make[2]: Leaving directory `/usr/src/oisf/src'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory `/usr/src/oisf'
>> make: *** [all] Error 2

Could you try building it like this - (just for the purpose of testing
and pinpointing the issue)?

git clone git://phalanx.openinfosecfoundation.org/oisf.git && cd oisf/
&& git clone https://github.com/ironbee/libhtp.git -b 0.5.x &&
./autogen.sh && ./configure --enable-geoip --enable-profiling
--with-libnspr-includes=/usr/include/nspr  &&  make clean &&  make &&
make install &&  ldconfig

Would you get the same err? I tried it like this and do not have that problem.

Peter Manev

More information about the Oisf-users mailing list