[Oisf-users] Unable to run inline in Windows

Peter Manev petermanev at gmail.com
Thu May 29 07:16:19 UTC 2014

On Thu, May 29, 2014 at 8:54 AM, Victor Julien <lists at inliniac.net> wrote:
> On 05/29/2014 01:59 AM, Aethrun wrote:
>>     I don't think this still works. netfilterforwin hasn't been maintained
>>     in ages. Also, it was created for mingw, not cygwin. Getting mingw to
>>     work has always been challenging in my experience.
>> I tried to install netfilterforwin in MinGW but configure quit with an
>> "unrecognized option -V" error, so I thought I'd see what happened in
>> Cygwin. I also tried installing libnfnetlink-1.0.1, the source of the
>> libnfnetlink.h file that Suricata needs, but it failed with the message,
>> "Linux only, dude!"

It looks like you know your way around with Linux, if I may:
What is the reason to run inline on Windows?

>> Is there anything I can do to get Suricata running in inline mode under
>> Windows or is it simply infeasible at this point?
> I think it's very unlikely to work.

Peter Manev

More information about the Oisf-users mailing list