[Oisf-users] Build error

Data King dataking at gmail.com
Tue Nov 25 00:34:54 UTC 2014


I'm trying to build suricata from source on a gentoo linux system.  I've
tried stable (2.0.4) and development (2.1beta) sources, and sources from
git.  All versions fail with the same error:

  CC       suricata.o
suricata.c: In function 'SCPrintBuildInfo':
suricata.c:795:50: error: 'defined' undeclared (first use in this function)
     printf("compiled with _FORTIFY_SOURCE=%d\n", _FORTIFY_SOURCE);
suricata.c:795:50: note: each undeclared identifier is reported only once
for each function it appears in
suricata.c:795:50: error: expected ')' before numeric constant
     printf("compiled with _FORTIFY_SOURCE=%d\n", _FORTIFY_SOURCE);
Makefile:1421: recipe for target 'suricata.o' failed
make[3]: *** [suricata.o] Error 1
make[3]: Leaving directory '/root/suricata-git/oisf/src'
Makefile:951: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/root/suricata-git/oisf/src'
Makefile:446: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/root/suricata-git/oisf'
Makefile:375: recipe for target 'all' failed
make: *** [all] Error 2

TIA for your assistance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openinfosecfoundation.org/pipermail/oisf-users/attachments/20141124/2311c1be/attachment.html>

More information about the Oisf-users mailing list