[Oisf-users] Suricata crashes running mpipe in tilera fr

Victor Julien lists at inliniac.net
Thu May 25 07:33:40 UTC 2017

Hi Ian,

On 20-05-17 11:21, Ian French wrote:
> Been struggling with this for a couple weeks now. My company has a few
> different Tilera machines, including the w
> Wildcat(?), the Garfield, and the FR. After reading about the results
> achieved using suricata on the tile architecture I attempted to try it
> out on the FR, it being the newest of our machines. 
> For whatever reason I cannot get suricata to run using mPipe without the
> whole box locking up and requiring a hard reset. I have tried using both
> the version available on github, as well as the ez-suricata tar package
> that was provided by Tilera. Suricata does run in other modes, but
> without mpipe there isnt nearly as much of a performance increase, at
> least not from what Ive seen on my machines, even with logging disabled
> and a barebones useragent rule set.
> Has anyone had this issue? I could post my yaml config, but aside from
> changing the mpipe interfaces everything else was left as is. I also
> noticed that there are some changes between the ez version and the one
> on github - the one on github requires libraries that I cannot seem to
> find as referenced to in the readme, which I solved by sourcing them
> elsewhere. Id like to assume this hasnt caused problems as they are both
> compiled from source, but I could be mistaken.
> If anyone is able to help I will gladly share whatever information or
> details requested. 

I think your best bet is to contact Tilera support about this. The team
isn't running & testing tilera hardware and it's likely that the latest
code is broken because of this. We'd be happy to work with ppl in the
community to get it back into shape (by which I mean accept patches),
but if that doesn't happen we'll probably start removing the support at
some point.

Victor Julien
PGP: http://www.inliniac.net/victorjulien.asc

More information about the Oisf-users mailing list