[Oisf-users] Is this a bug?

Victor Julien lists at inliniac.net
Fri Jan 11 10:09:57 UTC 2013

On 12/29/2012 03:05 AM, 郑博文 wrote:
> Hello:
>     I am reading suricata codes recently, I think the fisrt
> "ACTION_REJECT_BOTH" should change to "ACTION_REJECT_DST" in
> util-action.c file ActionOrderVal function line 56.

This is the code:

    if( (action & ACTION_REJECT) ||
        (action & ACTION_REJECT_BOTH) ||
        (action & ACTION_REJECT_DST)) {
        action = ACTION_REJECT;

How do you think it should be different? If ACTION_REJECT_BOTH would be
changed to ACTION_REJECT_DST the latter would appear twice.


Victor Julien
PGP: http://www.inliniac.net/victorjulien.asc

More information about the Oisf-users mailing list