[Oisf-users] Illegal operation (Suricata 2.1beta4)

Victor Julien lists at inliniac.net
Mon Jun 1 12:24:58 UTC 2015

On 06/01/2015 01:53 PM, Yasha Zislin wrote:
> I've created an RPM out of the source code of Suricata 2.1beta4.
> It works fine on a bunch of boxes except for one.
> I get the following error what I try to start the service.
> Suricata-Main[4177] trap invalid opcode ip:416895 sp:7fff21613e20
> error:0 in suricata[400000+1d3000]
> I run the following command to start:
> suricata -c /xxx/suricata.yaml --pfring -vv
> Running just suricata works fine.
> I get the same error if I try to use af-packet mode.
> This and working box have the same OS running (CentOS 6 64bit).
> The only difference that I notice is amount of RAM and monitored NICs.
> Non-working has an Intel card. But I've tried to start it for another
> interface with no luck.

The rpm's should be built with --disable-gccmarch-native passed to
configure. Otherwise they will have optimizations for the build host,
that may not work on different hardware.

Victor Julien
PGP: http://www.inliniac.net/victorjulien.asc

More information about the Oisf-users mailing list