[Oisf-users] CUDA ERROR

Julio Torres jctorres at warriorslabs.com
Wed Mar 22 17:49:37 UTC 2017


I'm working with inline ips but i'd like use CUDA features, currently I
have GTX 1060 on ubuntu 14.04 with cuda toolkit 8.0. 

I checked that everything works fine with cuda samples but when I tried
to build suricata enabling cuda I get some errors. 

util-cuda.c: In function 'SCCudaPrintDeviceList':
util-cuda.c:1133:60: error: 'CU_COMPUTEMODE_EXCLUSIVE' undeclared (first
use in this function)
 else if (devices->devices[i]->attr_compute_mode ==
util-cuda.c:1133:60: note: each undeclared identifier is reported only
once for each function it appears in
make[3]: *** [util-cuda.o] Error 1
make[3]: se sale del directorio «/home/wdips/oisf/src»
make[2]: *** [all] Error 2
make[2]: se sale del directorio «/home/wdips/oisf/src»
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio «/home/wdips/oisf»
make: *** [all] Error 2 

I've tried change compute mode to default mode: 
nvidia-smi -i 0 -c 0 

however that can't solve it. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openinfosecfoundation.org/pipermail/oisf-users/attachments/20170322/9651027d/attachment.html>

More information about the Oisf-users mailing list