[Oisf-users] CUDA ERROR

Jason Ish ish at unx.ca
Wed Mar 22 19:59:48 UTC 2017

On Wed, Mar 22, 2017 at 11:49 AM, Julio Torres <jctorres at warriorslabs.com>

> I'm working with inline ips but i'd like use CUDA features, currently I
> have GTX 1060 on ubuntu 14.04 with cuda toolkit 8.0.
> I checked that everything works fine with cuda samples but when I tried to
> build suricata enabling cuda I get some errors.
> util-cuda.c: In function ‘SCCudaPrintDeviceList’:
> util-cuda.c:1133:60: error: ‘CU_COMPUTEMODE_EXCLUSIVE’ undeclared (first
> use in this function)
> else if (devices->devices[i]->attr_compute_mode ==
>           ^
> util-cuda.c:1133:60: note: each undeclared identifier is reported only
> once for each function it appears in
> make[3]: *** [util-cuda.o] Error 1
> make[3]: se sale del directorio «/home/wdips/oisf/src»
> make[2]: *** [all] Error 2
> make[2]: se sale del directorio «/home/wdips/oisf/src»
> make[1]: *** [all-recursive] Error 1
> make[1]: se sale del directorio «/home/wdips/oisf»
> make: *** [all] Error 2
> I've tried change compute mode to default mode:
> nvidia-smi -i 0 -c 0
> however that can't solve it.
I've heard other people say they can't build it with v8.0 but some older
version works. However, the CUDA support is currently unmaintained and
unlikely to work even if you do get it to build. I don't think its ever
been really shown to improve performance either so it might not be worth
pursuing unless you are willing to take up development yourself.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openinfosecfoundation.org/pipermail/oisf-users/attachments/20170322/8e52849a/attachment-0002.html>

More information about the Oisf-users mailing list